Error -75 in xhci_hcd/usb3

Tags: 

avviso: unresolved

L'articolo tratta di un problema che non è stato ancora risolto. Quindi potrete trovare una descrizione del problema, riferimenti trovati in rete e i tentativi fatti per cercare di risolverlo. Ma non lo soluzione definitiva. Se volete contribuire con dei consigli, fatevi avanti!

Nuovo problema sulle porte USB3 (che poi questo non è nemmeno sulla reale porta USB3, ma riguarda comunque il driver linux xhci_hcd del controller USB).

Scenario: metto il mio galaxy tab in download mode, lo collego per lavorarci con heimdall, ma da questi bei messaggi:

lug 24 15:11:59 shodan kernel: usb 1-2: new high-speed USB device number 10 using xhci_hcd
 
lug 24 15:11:59 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:11:59 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:11:59 shodan kernel: usb 1-2: new high-speed USB device number 11 using xhci_hcd
 
lug 24 15:11:59 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:11:59 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:12:00 shodan kernel: usb 1-2: new high-speed USB device number 12 using xhci_hcd
 
lug 24 15:12:00 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:12:00 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:12:00 shodan kernel: usb 1-2: new high-speed USB device number 13 using xhci_hcd
 
lug 24 15:12:00 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:12:00 shodan kernel: usb 1-2: device descriptor read/8, error -75
 
lug 24 15:12:00 shodan kernel: hub 1-0:1.0: unable to enumerate USB device on port 2

Ovviamente il device non viene riconosciuto e non è utilizzabile...

Ho cercato in giro ma si trova solo altra gente che lamenta il problema, e nessuna soluzione.

Questo uno dei pochi thread che parla del problema specifico:

http://forum.xda-developers.com/showthread.php?t=2181052

Sull'altro mio pc, più vecchio e che usa ehci-pci invece di xhci_hcd, ovviamente funziona tutto bene.

Qualcuno ha delle idee ?

 

  • Nota: questo è solo l'ennesimo problema che riguarda, direttamente o indirittamente, xhci_hcd e le porta usb... sta diventando seccante...
  • Giusto per conoscenza, e solo i 2 problemi che ricordo (ne ho avuti altri che ora non ricordo...)
    - hard disk usb3 che, quando lo collegavo a computer accesso, mandava in kernel panic la macchina con crash globale e irreversibile (alla faccia di chi dice che su Linux il BSOD non esiste). Se lo collegavo prima di accendere la macchina andava, ma per poi dare 1000 problemi. Alla fine dopo un mucchio controlli c'era effettivamente un problema in alcuni settori dell'hard disk... (e la seagate me l'ha sostituito gratis). Resta il fatto che andare in kernel panic per un problema a dei settori del disco non va affatto bene per un SO serio! (Windows non dava nessun problema, semplicemente quando scriveva in quei settori dava degli errori, come è giusto che sia).
      Da notare che l'hard disk nuovo funziona, ma in un caso è capitato di nuovo che staccandolo e riattaccandolo sia andato in kernel panic... Quindi il sospetto che il problema sia tutto di xhci_hcd (magari anche il danneggiamento del vecchio) c'è...
    - MTP non funziona neanche per scherzo. Non ho ancora analizzato bene il problema (chepalledoverperdereunsaccodioreperrisolverequalunqueproblema!), sta di fatto che per andare sul mio android velocemente ho dovuto installargli un client sftp.......

     

    1000 volte viva Linux...

    ... ma qualche volta Linux F*ck!

    Aggiungi un commento